Browser Requirements:
Chrome - Requires the latest version, however Chrome will auto update for you.
Firefox - Requires the latest version, however Firefox will auto update for you.

The reason why JobFlow is limited to these two browsers is that by limiting to two browsers we are able to lower the development time and cost, which intern means more hours of development spent on features people what and also lower subscription fees.

Mobile App:
Android - Jelly Bean 4.2 or higher
Apple - iOS 9 or higher 

The mobile app will not function without the above requirements, however performance will be different on different devices.

Did this answer your question?